Installer checkpoint ssl extender vpn (snx) sous linux

Fonctionne aussi sous archlinux avec openjdk6
Référecnce:
http://kenfallon.com/how-to-install-checkpoint-ssl-extender-vpn-snx-under-fedora-14/

How to install Checkpoint ssl extender vpn (snx) under Fedora 14

Posted on 2010-11-21 by ken_fallon

This is the Fedora 14 AMD64 version of my previous post How to install Checkpoint ssl extender vpn (snx) under Debian/Kubuntu. Running the install is the same and hopefully will go without error.

./snx_install.sh

Unfortunately snx will not run complaining about missing libraries

[root@laptop checkpoint]# ldd /usr/bin/snx
        linux-gate.so.1 =>  (0xf773e000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf75f2000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf75d6000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xf75bc000)
        libdl.so.2 => /lib/libdl.so.2 (0x4c766000)
        libpam.so.0 => not found
        libnsl.so.1 => /lib/libnsl.so.1 (0xf75a0000)
        libstdc++.so.5 => not found
        libc.so.6 => /lib/libc.so.6 (0x4c5d0000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf7582000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf7564000)
        /lib/ld-linux.so.2 (0x4c5ac000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf7561000)

The solution for some of the problems are to install the following packages:

yum install compat-libstdc++-33.x86_64 compat-libstdc++-33.i686 audit-libs.i686

Unfortunately some problems remain

[root@laptop checkpoint]# ldd /usr/bin/snx | grep "not found"
        libpam.so.0 => not found

After getting a lot of help from JessiJames and thrice` on #oggcastplanet @ freenode we came up with this solution:

First get the i686 version of pam, then extract it, and finally link the libpam.so.0 to the new location.

wget ftp://rpmfind.net/linux/fedora/updates/14/x86_64/pam-1.1.1-6.fc14.i686.rpm
rpm2cpio pam-1.1.1-6.fc14.i686.rpm | cpio -idmv
mkdir /usr/local/lib/checkpoint32/
find| grep libpam.so.0
cp -v ./lib/libpam.so.0.82.2 /usr/local/lib/checkpoint32/
ln -s /usr/local/lib/checkpoint32/libpam.so.0.82.2 libpam.so.0

Hopefully that should fix it for you as well.

Publicités

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :